]> git.sev.monster Git - aports.git/blob - testing/mympd/APKBUILD
py3-iso3166: bump pkgrel for python update
[aports.git] / testing / mympd / APKBUILD
1 # Contributor: sev <alpine@sev.monster>
2 # Maintainer: sev <alpine@sev.monster>
3 pkgname=mympd
4 pkgver=10.1.5
5 pkgrel=0
6 pkgdesc="myMPD is a standalone and mobile friendly web-based MPD client."
7 url="https://jcorporation.github.io/myMPD/"
8 arch="all"
9 license="GPL-3.0-or-later"
10 # for ssl support
11 #depends="libid3tag flac openssl>=1.1.0 lua5.4-libs pcre2"
12 #makedepends="cmake>=3.4 perl libid3tag-dev flac-dev openssl>=1.1.0 linux-headers lua5.4-dev pcre2-dev jq"
13 depends="libid3tag flac lua5.4-libs pcre2"
14 makedepends="cmake>=3.4 perl libid3tag-dev flac-dev linux-headers lua5.4-dev pcre2-dev jq"
15 install="$pkgname.pre-install"
16 subpackages="$pkgname-doc $pkgname-openrc"
17 source="myMPD-$pkgver.tar.gz::https://github.com/jcorporation/myMPD/archive/refs/tags/v$pkgver.tar.gz"
18 builddir="$srcdir/myMPD-$pkgver"
19
20 build() {
21         cd "$builddir" || exit 1
22         ./build.sh release
23 }
24
25 check() {
26         cd "$builddir/release/bin" || exit 1
27         ./mympd -h >/dev/null 2>&1 || return 1
28         if [ -x cli_tools/mympd-script ]; then
29                 # we want to check exit code so we have to turn off errexit
30                 set +e
31                 ./mympd-script -h >/dev/null 2>&1
32                 [ $? -ne 1 ] && return 1
33                 set -e
34         fi
35 }
36
37 package() {
38         cd "$builddir/release" || exit 1
39         DESTDIR="$pkgdir" make install
40 }
41
42 sha512sums="
43 f6af54bb44298a26453fd2b749d1e4ac16f52359175d154db41f3832567854f75d924336a6ac86fa88124df12fdf208eb2f763a0bd8e5414ec7e1b8c59ecdcb5  myMPD-10.1.5.tar.gz
44 "
This page took 0.033154 seconds and 4 git commands to generate.