1 # Contributor: sev <alpine@sev.monster>
2 # Maintainer: sev <alpine@sev.monster>
6 pkgdesc="myMPD is a standalone and mobile friendly web-based MPD client."
7 url="https://jcorporation.github.io/myMPD/"
9 license="GPL-3.0-or-later"
11 #depends="libid3tag flac openssl>=1.1.0 lua5.4-libs pcre2"
12 #makedepends="cmake>=3.4 perl libid3tag-dev flac-dev openssl>=1.1.0 linux-headers lua5.4-dev pcre2-dev jq"
13 depends="libid3tag flac lua5.4-libs pcre2"
14 makedepends="cmake>=3.4 perl libid3tag-dev flac-dev linux-headers lua5.4-dev pcre2-dev jq"
15 install="$pkgname.pre-install"
16 subpackages="$pkgname-doc $pkgname-openrc"
17 source="myMPD-$pkgver.tar.gz::https://github.com/jcorporation/myMPD/archive/refs/tags/v$pkgver.tar.gz"
18 builddir="$srcdir/myMPD-$pkgver"
21 cd "$builddir" || exit 1
26 cd "$builddir/release" || exit 1
27 # mympd has no safe way to start without it doing something
28 [ -x mympd >/dev/null 2>&1 ] || return 1
29 # we want to check a specific exit code so we have to turn off errexit
31 if [ -x cli_tools/mympd-script ]; then
32 ./cli_tools/mympd-script -h >/dev/null 2>&1
33 [ $? -ne 1 ] && return 1
39 cd "$builddir/release" || exit 1
40 DESTDIR="$pkgdir" make install
44 ad0724208dd7b6f48fad5adef5275f4ecb4d743dd80864e2ad39f66f1238bab284dda462d893566ad772f89956bffecaf08b88108ad5a649a6153beb6283d9ee myMPD-9.3.4.tar.gz