]> git.sev.monster Git - aports.git/blob - testing/mympd/APKBUILD
mympd: bump version, cronwrap: use binary basename
[aports.git] / testing / mympd / APKBUILD
1 # Contributor: sev <alpine@sev.monster>
2 # Maintainer: sev <alpine@sev.monster>
3 pkgname=mympd
4 pkgver=8.0.2
5 pkgrel=1
6 pkgdesc="myMPD is a standalone and mobile friendly web mpd client with a tiny footprint and advanced features."
7 url="https://jcorporation.github.io"
8 arch="all"
9 license="GPL-2.0-or-later"
10 depends="libid3tag flac openssl>=1.1.0 lua5.3-libs pcre"
11 makedepends="cmake>=3.4 perl libid3tag-dev flac-dev openssl-dev>=1.1.0 linux-headers lua5.3-dev lua5.3-libs pcre-dev"
12 install="$pkgname.pre-install $pkgname.post-install"
13 subpackages="$pkgname-doc $pkgname-openrc"
14 source="myMPD-$pkgver.tar.gz::https://github.com/jcorporation/myMPD/archive/refs/tags/v$pkgver.tar.gz"
15 builddir="$srcdir/myMPD-$pkgver"
16
17 build() {
18         cd "$builddir"
19         ./build.sh release
20 }
21
22 check() {
23         cd "$builddir/release"
24         # mympd has no safe way to start without it doing something
25         [ -x mympd >/dev/null 2>&1 ] || return 1
26         # we want to check a specific exit code so we have to turn off errexit
27         set +e
28         for x in config script; do
29                 if [ -x cli_tools/mympd-$x ]; then
30                         ./cli_tools/mympd-$x -h >/dev/null 2>&1
31                         [ $? -ne 1 ] && return 1
32                 fi
33         done
34         set -e
35 }
36
37 package() {
38         cd "$builddir/release" || exit 1
39         [ -z "${DESTDIR+x}" ] && DESTDIR=""
40         make DESTDIR="$pkgdir" install
41 }
42
43 sha512sums="
44 7a49659fec8f4a6926fdf7d4ede5b625ba7e3a3f48c828b2103313a24582019577d13b2075457f1007c3d57839090eafc0392a0c2b569a74077c5ef0bbb08d7d  myMPD-8.0.2.tar.gz
45 "
This page took 0.041525 seconds and 4 git commands to generate.