]> git.sev.monster Git - aports.git/blob - testing/mympd/APKBUILD
mympd: update to 9.1.0
[aports.git] / testing / mympd / APKBUILD
1 # Contributor: sev <alpine@sev.monster>
2 # Maintainer: sev <alpine@sev.monster>
3 pkgname=mympd
4 pkgver=9.1.0
5 pkgrel=0
6 pkgdesc="myMPD is a standalone and mobile friendly web mpd client with a tiny footprint and advanced features."
7 url="https://jcorporation.github.io"
8 arch="all"
9 license="GPL-3.0"
10 # for ssl support
11 depends="libid3tag flac openssl>=1.1.0 lua5.4-libs pcre2"
12 makedepends="cmake>=3.4 perl libid3tag-dev flac-dev linux-headers lua5.4-dev lua5.4-libs pcre2-dev"
13 install="$pkgname.pre-install"
14 subpackages="$pkgname-doc $pkgname-openrc"
15 source="myMPD-$pkgver.tar.gz::https://github.com/jcorporation/myMPD/archive/refs/tags/v$pkgver.tar.gz"
16 builddir="$srcdir/myMPD-$pkgver"
17
18 build() {
19         cd "$builddir"
20         ./build.sh release
21 }
22
23 check() {
24         cd "$builddir/release"
25         # mympd has no safe way to start without it doing something
26         [ -x mympd >/dev/null 2>&1 ] || return 1
27         # we want to check a specific exit code so we have to turn off errexit
28         set +e
29         if [ -x cli_tools/mympd-script ]; then
30                 ./cli_tools/mympd-script -h >/dev/null 2>&1
31                 [ $? -ne 1 ] && return 1
32         fi
33         set -e
34 }
35
36 package() {
37         cd "$builddir/release" || exit 1
38         [ -z "${DESTDIR+x}" ] && DESTDIR=""
39         make DESTDIR="$pkgdir" install
40 }
41
42 sha512sums="
43 0edf284d4b146744d76433df0237e259e17ff9b4c5353dca7e257c4e1dceb66599926398d44da6928ace6c2306032170f249c2f63aa1a4646240be6d1abf0f8c  myMPD-9.1.0.tar.gz
44 "
This page took 0.041364 seconds and 4 git commands to generate.