]> git.sev.monster Git - aports.git/blob - testing/mympd/APKBUILD
update web2ldap, ldap0, mympd, motd
[aports.git] / testing / mympd / APKBUILD
1 # Contributor: sev <alpine@sev.monster>
2 # Maintainer: sev <alpine@sev.monster>
3 pkgname=mympd
4 pkgver=9.1.2
5 pkgrel=0
6 pkgdesc="myMPD is a standalone and mobile friendly web mpd client with a tiny footprint and advanced features."
7 url="https://jcorporation.github.io"
8 arch="all"
9 license="GPL-3.0"
10 # for ssl support
11 depends="libid3tag flac openssl>=1.1.0 lua5.4-libs pcre2"
12 makedepends="cmake>=3.4 perl libid3tag-dev flac-dev linux-headers lua5.4-dev lua5.4-libs pcre2-dev"
13 install="$pkgname.pre-install"
14 subpackages="$pkgname-doc $pkgname-openrc"
15 source="myMPD-$pkgver.tar.gz::https://github.com/jcorporation/myMPD/archive/refs/tags/v$pkgver.tar.gz"
16 builddir="$srcdir/myMPD-$pkgver"
17
18 build() {
19         cd "$builddir"
20         ./build.sh release
21 }
22
23 check() {
24         cd "$builddir/release"
25         # mympd has no safe way to start without it doing something
26         [ -x mympd >/dev/null 2>&1 ] || return 1
27         # we want to check a specific exit code so we have to turn off errexit
28         set +e
29         if [ -x cli_tools/mympd-script ]; then
30                 ./cli_tools/mympd-script -h >/dev/null 2>&1
31                 [ $? -ne 1 ] && return 1
32         fi
33         set -e
34 }
35
36 package() {
37         cd "$builddir/release" || exit 1
38         [ -z "${DESTDIR+x}" ] && DESTDIR=""
39         make DESTDIR="$pkgdir" install
40 }
41
42 sha512sums="
43 fe16a38861daa87b16d72a6fcc4d7003f1b84e535da1e40c3dea3a04776c98881a6e658684b376ae1d2d0c366352f111c5d93f224c8315904ff0e61e36a4cf5c  myMPD-9.1.2.tar.gz
44 "
This page took 0.037852 seconds and 4 git commands to generate.