1 # Contributor: sev <alpine@sev.monster>
2 # Maintainer: sev <alpine@sev.monster>
6 pkgdesc="myMPD is a standalone and mobile friendly web mpd client with a tiny footprint and advanced features."
7 url="https://jcorporation.github.io"
11 depends="libid3tag flac openssl>=1.1.0 lua5.4-libs pcre2"
12 makedepends="cmake>=3.4 perl libid3tag-dev flac-dev linux-headers lua5.4-dev lua5.4-libs pcre2-dev"
13 install="$pkgname.pre-install"
14 subpackages="$pkgname-doc $pkgname-openrc"
15 source="myMPD-$pkgver.tar.gz::https://github.com/jcorporation/myMPD/archive/refs/tags/v$pkgver.tar.gz"
16 builddir="$srcdir/myMPD-$pkgver"
24 cd "$builddir/release"
25 # mympd has no safe way to start without it doing something
26 [ -x mympd >/dev/null 2>&1 ] || return 1
27 # we want to check a specific exit code so we have to turn off errexit
29 if [ -x cli_tools/mympd-script ]; then
30 ./cli_tools/mympd-script -h >/dev/null 2>&1
31 [ $? -ne 1 ] && return 1
37 cd "$builddir/release" || exit 1
38 [ -z "${DESTDIR+x}" ] && DESTDIR=""
39 make DESTDIR="$pkgdir" install
43 fe16a38861daa87b16d72a6fcc4d7003f1b84e535da1e40c3dea3a04776c98881a6e658684b376ae1d2d0c366352f111c5d93f224c8315904ff0e61e36a4cf5c myMPD-9.1.2.tar.gz