1 # Contributor: sev <alpine@sev.monster>
2 # Maintainer: sev <alpine@sev.monster>
6 pkgdesc="myMPD is a standalone and mobile friendly web mpd client with a tiny footprint and advanced features."
7 url="https://jcorporation.github.io"
11 depends="libid3tag flac openssl>=1.1.0 lua5.4-libs pcre2"
12 makedepends="cmake>=3.4 perl libid3tag-dev flac-dev linux-headers lua5.4-dev lua5.4-libs pcre2-dev"
13 install="$pkgname.pre-install"
14 subpackages="$pkgname-doc $pkgname-openrc"
15 source="myMPD-$pkgver.tar.gz::https://github.com/jcorporation/myMPD/archive/refs/tags/v$pkgver.tar.gz"
16 builddir="$srcdir/myMPD-$pkgver"
24 cd "$builddir/release"
25 # mympd has no safe way to start without it doing something
26 [ -x mympd >/dev/null 2>&1 ] || return 1
27 # we want to check a specific exit code so we have to turn off errexit
29 if [ -x cli_tools/mympd-script ]; then
30 ./cli_tools/mympd-script -h >/dev/null 2>&1
31 [ $? -ne 1 ] && return 1
37 cd "$builddir/release" || exit 1
38 [ -z "${DESTDIR+x}" ] && DESTDIR=""
39 make DESTDIR="$pkgdir" install
43 0b9bf8ba68bd9b892c0e0bd83e9efc2763038eeadc604f2c977390716f95e5a5cd608be24548d9e01608ebd7f0737a0ed279f002ab07e8ed8ce8629458bfc892 myMPD-9.0.0.tar.gz