]> git.sev.monster Git - aports.git/blob - testing/mympd/APKBUILD
mympd: update to 10.3.0 beta
[aports.git] / testing / mympd / APKBUILD
1 # Contributor: sev <alpine@sev.monster>
2 # Maintainer: sev <alpine@sev.monster>
3 pkgname=mympd
4 pkgver=10.3.0
5 pkgrel=1
6 pkgdesc="myMPD is a standalone and mobile friendly web-based MPD client."
7 url="https://jcorporation.github.io/myMPD/"
8 arch="all"
9 license="GPL-3.0-or-later"
10 # for ssl support
11 #depends="libid3tag flac openssl>=1.1.0 lua5.4-libs pcre2"
12 #makedepends="cmake>=3.4 perl libid3tag-dev flac-dev openssl>=1.1.0 linux-headers lua5.4-dev pcre2-dev jq"
13 depends="libid3tag flac lua5.4-libs pcre2"
14 makedepends="cmake>=3.4 perl libid3tag-dev flac-dev linux-headers lua5.4-dev pcre2-dev jq"
15 install="$pkgname.pre-install"
16 subpackages="$pkgname-doc $pkgname-openrc"
17 source="myMPD-$pkgver.tar.gz::https://github.com/jcorporation/myMPD/archive/refs/heads/v$pkgver.tar.gz"
18 builddir="$srcdir/myMPD-$pkgver"
19
20 build() {
21         cd "$builddir" || exit 1
22         ./build.sh release
23 }
24
25 check() {
26         cd "$builddir/release/bin" || exit 1
27         ./mympd -h >/dev/null 2>&1 || return 1
28         if [ -x cli_tools/mympd-script ]; then
29                 # we want to check exit code so we have to turn off errexit
30                 set +e
31                 ./mympd-script -h >/dev/null 2>&1
32                 [ $? -ne 1 ] && return 1
33                 set -e
34         fi
35 }
36
37 package() {
38         cd "$builddir/release" || exit 1
39         DESTDIR="$pkgdir" make install
40 }
41
42 sha512sums="
43 8c0d4aa0d26ca42b96e8ed50db4e7a8f23b8f81f1534e29c29334842735c1a77a6ad8ad785c28afe558e2b26078eae50aef4a9af9f26dc24760dd0b63afccb8f  myMPD-10.3.0.tar.gz
44 "
This page took 0.033341 seconds and 4 git commands to generate.