]> git.sev.monster Git - aports.git/blob - testing/mympd/APKBUILD
testing/mympd: upgrade to 18.0.0
[aports.git] / testing / mympd / APKBUILD
1 # Contributor: sev <sev+alpine@sev.monster>
2 # Maintainer: sev <sev+alpine@sev.monster>
3 # Based on upstream APKBUILD
4 # https://github.com/jcorporation/myMPD/blob/master/contrib/packaging/alpine/APKBUILD.in
5 pkgname=mympd
6 _pkgver=16.0.0
7 pkgver=18.0.0
8 pkgrel=0
9 pkgdesc="myMPD is a standalone and mobile friendly web-based MPD client."
10 url="https://jcorporation.github.io/myMPD/"
11 arch="all"
12 license="GPL-3.0-or-later"
13 depends="libid3tag flac openssl>=1.1.0 lua5.4-libs pcre2"
14 makedepends="cmake>=3.4 perl libid3tag-dev flac-dev openssl-dev>=1.1.0 linux-headers lua5.4-dev pcre2-dev jq"
15 install="$pkgname.pre-install"
16 subpackages="$pkgname-doc $pkgname-openrc $pkgname-dbg"
17 #source="myMPD-$pkgver.tar.gz::https://github.com/jcorporation/myMPD/archive/refs/tags/v$pkgver.tar.gz"
18 source="myMPD-$_pkgver.tar.gz::https://github.com/jcorporation/myMPD/archive/refs/heads/v16.0.0.tar.gz"
19 builddir="$srcdir/myMPD-$_pkgver"
20
21 build() {
22         cd "$builddir" || exit 1
23         ./build.sh release
24 }
25
26 check() {
27         cd "$builddir/release/bin" || exit 1
28         ./mympd -h >/dev/null 2>&1 || return 1
29         if [ -x cli_tools/mympd-script ]; then
30                 # we want to check exit code so we have to turn off errexit
31                 set +e
32                 ./mympd-script -h >/dev/null 2>&1
33                 [ $? -ne 1 ] && return 1
34                 set -e
35         fi
36 }
37
38 package() {
39         cd "$builddir/release" || exit 1
40         DESTDIR="$pkgdir" make install
41 }
42
43 sha512sums="
44 3cc3e286acc07ad17e5c2d94376d2b7b4c6204056196587105ba7477f60c08c1ffebc2748836d2fda64c014c480fe7cfc6d407b7cd665d89fc90cd250ac37520  myMPD-16.0.0.tar.gz
45 "
This page took 0.046403 seconds and 4 git commands to generate.