]> git.sev.monster Git - aports.git/blob - testing/py3-iso3166/APKBUILD
testing/py3-iso3166: fix tests
[aports.git] / testing / py3-iso3166 / APKBUILD
1 # Contributor: sev <alpine@sev.monster>
2 # Maintainer: sev <alpine@sev.monster>
3 _pkgname=iso3166
4 pkgname=py3-$_pkgname
5 pkgver=2.1.1
6 pkgrel=1
7 pkgdesc="Self-contained ISO 3166-1 country definitions."
8 url="https://github.com/deactivated/python-iso3166"
9 arch="noarch"
10 license="MIT"
11 depends="python3>=3.6"
12 makedepends="py3-setuptools"
13 checkdepends="py3-pytest"
14 source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
15 builddir="$srcdir"/$_pkgname-$pkgver
16
17 check() {
18         PYTHONPATH="$builddir"/build/lib py.test
19 }
20
21 build() {
22         python3 setup.py build
23 }
24
25 package() {
26         python3 setup.py install --prefix=/usr --root="$pkgdir"
27 }
28
29 sha512sums="
30 b427c58ab44abd21a985b0d2b0ea48576cd0fd0d4383d7c53492961d3649c7829acebff66984ce74a02b4f3315c3cfc57dc29fd033f6d6dd7606aca43bfb6401  iso3166-2.1.1.tar.gz
31 "
This page took 0.038375 seconds and 4 git commands to generate.