]> git.sev.monster Git - aports.git/blob - testing/mympd/APKBUILD
mympd: update to 9.3.1
[aports.git] / testing / mympd / APKBUILD
1 # Contributor: sev <alpine@sev.monster>
2 # Maintainer: sev <alpine@sev.monster>
3 pkgname=mympd
4 pkgver=9.3.1
5 pkgrel=0
6 pkgdesc="myMPD is a standalone and mobile friendly web-based MPD client."
7 url="https://jcorporation.github.io/myMPD/"
8 arch="all"
9 license="GPL-3.0-or-later"
10 # for ssl support
11 #depends="libid3tag flac openssl>=1.1.0 lua5.4-libs pcre2"
12 #makedepends="cmake>=3.4 perl libid3tag-dev flac-dev openssl>=1.1.0 linux-headers lua5.4-dev pcre2-dev jq"
13 depends="libid3tag flac lua5.4-libs pcre2"
14 makedepends="cmake>=3.4 perl libid3tag-dev flac-dev linux-headers lua5.4-dev pcre2-dev jq"
15 install="$pkgname.pre-install"
16 subpackages="$pkgname-doc $pkgname-openrc"
17 source="myMPD-$pkgver.tar.gz::https://github.com/jcorporation/myMPD/archive/refs/tags/v$pkgver.tar.gz"
18 builddir="$srcdir/myMPD-$pkgver"
19
20 build() {
21         cd "$builddir" || exit 1
22         ./build.sh release
23 }
24
25 check() {
26         cd "$builddir/release" || exit 1
27         # mympd has no safe way to start without it doing something
28         [ -x mympd >/dev/null 2>&1 ] || return 1
29         # we want to check a specific exit code so we have to turn off errexit
30         set +e
31         if [ -x cli_tools/mympd-script ]; then
32                 ./cli_tools/mympd-script -h >/dev/null 2>&1
33                 [ $? -ne 1 ] && return 1
34         fi
35         set -e
36 }
37
38 package() {
39         cd "$builddir/release" || exit 1
40         DESTDIR="$pkgdir" make install
41 }
42
43 sha512sums="
44 a5c8d63842d7c5139af465d0b065913a1d9f648bcfff8f0ad0d2055ad10cdcb525fd6f0fbba61ef513f868779192e67bfbc7c7e3508e00f79149e1de1fe90a63  myMPD-9.3.1.tar.gz
45 "
This page took 0.047245 seconds and 4 git commands to generate.