]> git.sev.monster Git - aports.git/blob - testing/mympd/APKBUILD
testing/mympd: upgrade to 13.0.6
[aports.git] / testing / mympd / APKBUILD
1 # Contributor: sev <alpine@sev.monster>
2 # Maintainer: sev <alpine@sev.monster>
3 # Based on upstream APKBUILD
4 # https://github.com/jcorporation/myMPD/blob/master/contrib/packaging/alpine/APKBUILD.in
5 pkgname=mympd
6 pkgver=13.0.6
7 pkgrel=0
8 pkgdesc="myMPD is a standalone and mobile friendly web-based MPD client."
9 url="https://jcorporation.github.io/myMPD/"
10 arch="all"
11 license="GPL-3.0-or-later"
12 depends="libid3tag flac openssl>=1.1.0 lua5.4-libs pcre2"
13 makedepends="cmake>=3.4 perl libid3tag-dev flac-dev openssl-dev>=1.1.0 linux-headers lua5.4-dev pcre2-dev jq"
14 install="$pkgname.pre-install"
15 subpackages="$pkgname-doc $pkgname-openrc $pkgname-dbg"
16 source="myMPD-$pkgver.tar.gz::https://github.com/jcorporation/myMPD/archive/refs/tags/v$pkgver.tar.gz"
17 builddir="$srcdir/myMPD-$pkgver"
18
19 build() {
20         cd "$builddir" || exit 1
21         ./build.sh release
22 }
23
24 check() {
25         cd "$builddir/release/bin" || exit 1
26         ./mympd -h >/dev/null 2>&1 || return 1
27         if [ -x cli_tools/mympd-script ]; then
28                 # we want to check exit code so we have to turn off errexit
29                 set +e
30                 ./mympd-script -h >/dev/null 2>&1
31                 [ $? -ne 1 ] && return 1
32                 set -e
33         fi
34 }
35
36 package() {
37         cd "$builddir/release" || exit 1
38         DESTDIR="$pkgdir" make install
39 }
40
41 sha512sums="
42 bb4c6b02b81e5b3ee4b0953ed4815faed74d8ab28c70c0228efa539771714d691b2955f8bf296e0e7e7785a1b8a50768e50a5c8a1bbfe358f25df70e380c30cf  myMPD-13.0.6.tar.gz
43 "
This page took 0.036159 seconds and 4 git commands to generate.