]> git.sev.monster Git - aports.git/blob - testing/py3-apprise/APKBUILD
py3-apprise: new package
[aports.git] / testing / py3-apprise / APKBUILD
1 # Contributor: sev <alpine@sev.monster>
2 # Maintainer: sev <alpine@sev.monster>
3 _pkgname=apprise
4 pkgname=py3-$_pkgname
5 pkgver=0.9.9
6 pkgrel=2
7 pkgdesc="Push Notifications that work with just about every platform!"
8 url="https://github.com/caronc/apprise"
9 arch="noarch"
10 license="MIT"
11 depends="py3-requests py3-requests-oauthlib py3-six py3-click>=5.0 py3-markdown py3-yaml"
12 makedepends="py3-pip py3-wheel"
13 subpackages="$pkgname-doc"
14 source="https://github.com/caronc/$_pkgname/archive/v$pkgver/$_pkgname-$pkgver.tar.gz"
15 builddir="$srcdir/$_pkgname-$pkgver"
16
17 build() {
18         python3 setup.py build
19 }
20
21 check() {
22         python3 setup.py check
23 }
24
25 package() {
26         python3 setup.py install --prefix=/usr --root="$pkgdir"
27         gzip packaging/man/apprise.1
28         mkdir -p "$pkgdir"-doc/usr/share/man/man1
29         mv packaging/man/apprise.1.gz "$pkgdir"-doc/usr/share/man/man1
30 }
31 sha512sums="
32 599bbd75a002fe8662f13294db2b7a4ce5cfe7c5cb33f6c5ac8515e2bf47adb25d95551f2945efcf84ed8139d4862fc0d832de8ba26667ef3e24153b5aea79b4  apprise-0.9.9.tar.gz
33 "
This page took 0.034323 seconds and 4 git commands to generate.