]> git.sev.monster Git - aports.git/blob - testing/py3-apprise/APKBUILD
testing/py3-apprise: upgrade to 1.2.0
[aports.git] / testing / py3-apprise / APKBUILD
1 # Contributor: sev <alpine@sev.monster>
2 # Maintainer: sev <alpine@sev.monster>
3 _pkgname=apprise
4 pkgname=py3-$_pkgname
5 pkgver=1.2.0
6 pkgrel=0
7 pkgdesc="Push Notifications that work with just about every platform!"
8 url="https://github.com/caronc/apprise"
9 arch="noarch"
10 license="MIT"
11 depends="py3-requests py3-requests-oauthlib py3-six py3-click>=5.0 py3-markdown py3-yaml"
12 makedepends="py3-pip py3-wheel"
13 subpackages="$pkgname-doc"
14 source="https://github.com/caronc/$_pkgname/archive/v$pkgver/$_pkgname-$pkgver.tar.gz"
15 builddir="$srcdir/$_pkgname-$pkgver"
16
17 build() {
18         python3 setup.py build
19 }
20
21 check() {
22         python3 setup.py check
23 }
24
25 package() {
26         python3 setup.py install --prefix=/usr --root="$pkgdir"
27         gzip packaging/man/apprise.1
28         mkdir -p "$pkgdir"-doc/usr/share/man/man1
29         mv packaging/man/apprise.1.gz "$pkgdir"-doc/usr/share/man/man1
30 }
31 sha512sums="
32 b1b08c095ce067bd58c4efae3ab19e05bcfb074b8bc41a7147c5b99e34c3cdf7f3004637edee8c561a2e3706a37b61d5cf99d550248466f5304b9f7b15cc3e22  apprise-1.2.0.tar.gz
33 "
This page took 0.041077 seconds and 4 git commands to generate.