-# Contributor: sev <alpine@sev.monster>
-# Maintainer: sev <alpine@sev.monster>
+# Contributor: sev <sev+alpine@sev.monster>
+# Maintainer: sev <sev+alpine@sev.monster>
+# Based on upstream APKBUILD
+# https://github.com/jcorporation/myMPD/blob/master/contrib/packaging/alpine/APKBUILD.in
pkgname=mympd
-pkgver=9.1.0
+_pkgver=16.0.0
+pkgver=18.1.2
pkgrel=0
-pkgdesc="myMPD is a standalone and mobile friendly web mpd client with a tiny footprint and advanced features."
-url="https://jcorporation.github.io"
+pkgdesc="myMPD is a standalone and mobile friendly web-based MPD client."
+url="https://jcorporation.github.io/myMPD/"
arch="all"
-license="GPL-3.0"
-# for ssl support
+license="GPL-3.0-or-later"
depends="libid3tag flac openssl>=1.1.0 lua5.4-libs pcre2"
-makedepends="cmake>=3.4 perl libid3tag-dev flac-dev linux-headers lua5.4-dev lua5.4-libs pcre2-dev"
+makedepends="cmake>=3.4 perl libid3tag-dev flac-dev openssl-dev>=1.1.0 linux-headers lua5.4-dev pcre2-dev jq"
install="$pkgname.pre-install"
-subpackages="$pkgname-doc $pkgname-openrc"
-source="myMPD-$pkgver.tar.gz::https://github.com/jcorporation/myMPD/archive/refs/tags/v$pkgver.tar.gz"
-builddir="$srcdir/myMPD-$pkgver"
+subpackages="$pkgname-doc $pkgname-openrc $pkgname-dbg"
+#source="myMPD-$pkgver.tar.gz::https://github.com/jcorporation/myMPD/archive/refs/tags/v$pkgver.tar.gz"
+source="myMPD-$_pkgver.tar.gz::https://github.com/jcorporation/myMPD/archive/refs/heads/v16.0.0.tar.gz"
+builddir="$srcdir/myMPD-$_pkgver"
build() {
- cd "$builddir"
+ cd "$builddir" || exit 1
./build.sh release
}
check() {
- cd "$builddir/release"
- # mympd has no safe way to start without it doing something
- [ -x mympd >/dev/null 2>&1 ] || return 1
- # we want to check a specific exit code so we have to turn off errexit
- set +e
+ cd "$builddir/release/bin" || exit 1
+ ./mympd -h >/dev/null 2>&1 || return 1
if [ -x cli_tools/mympd-script ]; then
- ./cli_tools/mympd-script -h >/dev/null 2>&1
+ # we want to check exit code so we have to turn off errexit
+ set +e
+ ./mympd-script -h >/dev/null 2>&1
[ $? -ne 1 ] && return 1
+ set -e
fi
- set -e
}
package() {
cd "$builddir/release" || exit 1
- [ -z "${DESTDIR+x}" ] && DESTDIR=""
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" make install
}
sha512sums="
-0edf284d4b146744d76433df0237e259e17ff9b4c5353dca7e257c4e1dceb66599926398d44da6928ace6c2306032170f249c2f63aa1a4646240be6d1abf0f8c myMPD-9.1.0.tar.gz
+3cc3e286acc07ad17e5c2d94376d2b7b4c6204056196587105ba7477f60c08c1ffebc2748836d2fda64c014c480fe7cfc6d407b7cd665d89fc90cd250ac37520 myMPD-16.0.0.tar.gz
"