]> git.sev.monster Git - aports.git/blobdiff - testing/mympd/APKBUILD
testing/mympd: upgrade to 14.0.2
[aports.git] / testing / mympd / APKBUILD
index 3a3fc2cce5ee41771670c10242d87e5fcbdd05c6..ba0d25a4592917dc4796513ffa709b699f659fce 100644 (file)
@@ -1,43 +1,43 @@
-# Contributor: sev <alpine@sev.monster>
-# Maintainer: sev <alpine@sev.monster>
+# Contributor: sev <sev+alpine@sev.monster>
+# Maintainer: sev <sev+alpine@sev.monster>
+# Based on upstream APKBUILD
+# https://github.com/jcorporation/myMPD/blob/master/contrib/packaging/alpine/APKBUILD.in
 pkgname=mympd
-pkgver=7.0.2
-pkgrel=1
-pkgdesc="myMPD is a standalone and mobile friendly web mpd client with a tiny footprint and advanced features."
-url="https://jcorporation.github.io"
+pkgver=14.0.2
+pkgrel=0
+pkgdesc="myMPD is a standalone and mobile friendly web-based MPD client."
+url="https://jcorporation.github.io/myMPD/"
 arch="all"
-license="GPL-2.0-or-later"
-depends="libid3tag flac openssl>=1.1.0 lua5.3 pcre"
-makedepends="cmake>=3.4 perl pcre-dev openssl-dev>=1.1.0 libid3tag-dev flac-dev lua5.3-dev"
-install="$pkgname.pre-install $pkgname.post-install"
-subpackages="$pkgname-doc $pkgname-openrc"
+license="GPL-3.0-or-later"
+depends="libid3tag flac openssl>=1.1.0 lua5.4-libs pcre2"
+makedepends="cmake>=3.4 perl libid3tag-dev flac-dev openssl-dev>=1.1.0 linux-headers lua5.4-dev pcre2-dev jq"
+install="$pkgname.pre-install"
+subpackages="$pkgname-doc $pkgname-openrc $pkgname-dbg"
 source="myMPD-$pkgver.tar.gz::https://github.com/jcorporation/myMPD/archive/refs/tags/v$pkgver.tar.gz"
 builddir="$srcdir/myMPD-$pkgver"
 
 build() {
-       cd "$builddir"
+       cd "$builddir" || exit 1
        ./build.sh release
 }
 
 check() {
-       cd "$builddir/release"
-       # mympd has no safe way to start without it doing something
-       [ -x mympd >/dev/null 2>&1 ] || return 1
-       # we want to check a specific exit code so we have to turn off errexit
-       set +e
-       for x in config script; do
-               ./cli_tools/mympd-$x -h >/dev/null 2>&1
+       cd "$builddir/release/bin" || exit 1
+       ./mympd -h >/dev/null 2>&1 || return 1
+       if [ -x cli_tools/mympd-script ]; then
+               # we want to check exit code so we have to turn off errexit
+               set +e
+               ./mympd-script -h >/dev/null 2>&1
                [ $? -ne 1 ] && return 1
-       done
-       set -e
+               set -e
+       fi
 }
 
 package() {
        cd "$builddir/release" || exit 1
-       [ -z "${DESTDIR+x}" ] && DESTDIR=""
-       make DESTDIR="$pkgdir" install
+       DESTDIR="$pkgdir" make install
 }
 
 sha512sums="
-98a7464c307797b5b3b3ab56a7dfc2bab47a366e4cc4c48c2239915a14152bd3d6946219ee634baf4a1d36ba92778393100e3e7a16054aa1f85381c34303bd3f  myMPD-7.0.2.tar.gz
+5e16079e62c6ef8dcdb5f120a732235b0a56428b955a1ec44a041cf467454f6b7184002cad6984ee9bd768ed8d6263e185bc5f2beeeffe05eb00086dc89bd2bf  myMPD-14.0.2.tar.gz
 "
This page took 0.038966 seconds and 4 git commands to generate.