# Contributor: sev <alpine@sev.monster>
# Maintainer: sev <alpine@sev.monster>
pkgname=mympd
-pkgver=7.0.2
-pkgrel=1
-pkgdesc="myMPD is a standalone and mobile friendly web mpd client with a tiny footprint and advanced features."
-url="https://jcorporation.github.io"
+pkgver=9.3.1
+pkgrel=0
+pkgdesc="myMPD is a standalone and mobile friendly web-based MPD client."
+url="https://jcorporation.github.io/myMPD/"
arch="all"
-license="GPL-2.0-or-later"
-depends="libid3tag flac openssl>=1.1.0 lua5.3 pcre"
-makedepends="cmake>=3.4 perl pcre-dev openssl-dev>=1.1.0 libid3tag-dev flac-dev lua5.3-dev"
-install="$pkgname.pre-install $pkgname.post-install"
+license="GPL-3.0-or-later"
+# for ssl support
+#depends="libid3tag flac openssl>=1.1.0 lua5.4-libs pcre2"
+#makedepends="cmake>=3.4 perl libid3tag-dev flac-dev openssl>=1.1.0 linux-headers lua5.4-dev pcre2-dev jq"
+depends="libid3tag flac lua5.4-libs pcre2"
+makedepends="cmake>=3.4 perl libid3tag-dev flac-dev linux-headers lua5.4-dev pcre2-dev jq"
+install="$pkgname.pre-install"
subpackages="$pkgname-doc $pkgname-openrc"
source="myMPD-$pkgver.tar.gz::https://github.com/jcorporation/myMPD/archive/refs/tags/v$pkgver.tar.gz"
builddir="$srcdir/myMPD-$pkgver"
build() {
- cd "$builddir"
+ cd "$builddir" || exit 1
./build.sh release
}
check() {
- cd "$builddir/release"
+ cd "$builddir/release" || exit 1
# mympd has no safe way to start without it doing something
[ -x mympd >/dev/null 2>&1 ] || return 1
# we want to check a specific exit code so we have to turn off errexit
set +e
- for x in config script; do
- ./cli_tools/mympd-$x -h >/dev/null 2>&1
+ if [ -x cli_tools/mympd-script ]; then
+ ./cli_tools/mympd-script -h >/dev/null 2>&1
[ $? -ne 1 ] && return 1
- done
+ fi
set -e
}
package() {
cd "$builddir/release" || exit 1
- [ -z "${DESTDIR+x}" ] && DESTDIR=""
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" make install
}
sha512sums="
-98a7464c307797b5b3b3ab56a7dfc2bab47a366e4cc4c48c2239915a14152bd3d6946219ee634baf4a1d36ba92778393100e3e7a16054aa1f85381c34303bd3f myMPD-7.0.2.tar.gz
+a5c8d63842d7c5139af465d0b065913a1d9f648bcfff8f0ad0d2055ad10cdcb525fd6f0fbba61ef513f868779192e67bfbc7c7e3508e00f79149e1de1fe90a63 myMPD-9.3.1.tar.gz
"