]> git.sev.monster Git - aports.git/blobdiff - testing/mympd/APKBUILD
mympd: update to 10.3.0 beta
[aports.git] / testing / mympd / APKBUILD
index cfe09bdd19f8988f82380603708910f3b5ebcae9..b584482053753c9e69f6899ae93457e5c89edd7c 100644 (file)
@@ -1,45 +1,44 @@
 # Contributor: sev <alpine@sev.monster>
 # Maintainer: sev <alpine@sev.monster>
 pkgname=mympd
-pkgver=8.0.2
+pkgver=10.3.0
 pkgrel=1
-pkgdesc="myMPD is a standalone and mobile friendly web mpd client with a tiny footprint and advanced features."
-url="https://jcorporation.github.io"
+pkgdesc="myMPD is a standalone and mobile friendly web-based MPD client."
+url="https://jcorporation.github.io/myMPD/"
 arch="all"
-license="GPL-2.0-or-later"
-depends="libid3tag flac openssl>=1.1.0 lua5.3-libs pcre"
-makedepends="cmake>=3.4 perl libid3tag-dev flac-dev openssl-dev>=1.1.0 linux-headers lua5.3-dev lua5.3-libs pcre-dev"
-install="$pkgname.pre-install $pkgname.post-install"
+license="GPL-3.0-or-later"
+# for ssl support
+#depends="libid3tag flac openssl>=1.1.0 lua5.4-libs pcre2"
+#makedepends="cmake>=3.4 perl libid3tag-dev flac-dev openssl>=1.1.0 linux-headers lua5.4-dev pcre2-dev jq"
+depends="libid3tag flac lua5.4-libs pcre2"
+makedepends="cmake>=3.4 perl libid3tag-dev flac-dev linux-headers lua5.4-dev pcre2-dev jq"
+install="$pkgname.pre-install"
 subpackages="$pkgname-doc $pkgname-openrc"
-source="myMPD-$pkgver.tar.gz::https://github.com/jcorporation/myMPD/archive/refs/tags/v$pkgver.tar.gz"
+source="myMPD-$pkgver.tar.gz::https://github.com/jcorporation/myMPD/archive/refs/heads/v$pkgver.tar.gz"
 builddir="$srcdir/myMPD-$pkgver"
 
 build() {
-       cd "$builddir"
+       cd "$builddir" || exit 1
        ./build.sh release
 }
 
 check() {
-       cd "$builddir/release"
-       # mympd has no safe way to start without it doing something
-       [ -x mympd >/dev/null 2>&1 ] || return 1
-       # we want to check a specific exit code so we have to turn off errexit
-       set +e
-       for x in config script; do
-               if [ -x cli_tools/mympd-$x ]; then
-                       ./cli_tools/mympd-$x -h >/dev/null 2>&1
-                       [ $? -ne 1 ] && return 1
-               fi
-       done
-       set -e
+       cd "$builddir/release/bin" || exit 1
+       ./mympd -h >/dev/null 2>&1 || return 1
+       if [ -x cli_tools/mympd-script ]; then
+               # we want to check exit code so we have to turn off errexit
+               set +e
+               ./mympd-script -h >/dev/null 2>&1
+               [ $? -ne 1 ] && return 1
+               set -e
+       fi
 }
 
 package() {
        cd "$builddir/release" || exit 1
-       [ -z "${DESTDIR+x}" ] && DESTDIR=""
-       make DESTDIR="$pkgdir" install
+       DESTDIR="$pkgdir" make install
 }
 
 sha512sums="
-7a49659fec8f4a6926fdf7d4ede5b625ba7e3a3f48c828b2103313a24582019577d13b2075457f1007c3d57839090eafc0392a0c2b569a74077c5ef0bbb08d7d  myMPD-8.0.2.tar.gz
+8c0d4aa0d26ca42b96e8ed50db4e7a8f23b8f81f1534e29c29334842735c1a77a6ad8ad785c28afe558e2b26078eae50aef4a9af9f26dc24760dd0b63afccb8f  myMPD-10.3.0.tar.gz
 "
This page took 0.039434 seconds and 4 git commands to generate.