]> git.sev.monster Git - aports.git/blobdiff - testing/mympd/APKBUILD
mympd: update to 10.3.0 beta
[aports.git] / testing / mympd / APKBUILD
index 9af6bd5b819d26ee3609a0861c4c840cfbcf9304..b584482053753c9e69f6899ae93457e5c89edd7c 100644 (file)
@@ -1,8 +1,8 @@
 # Contributor: sev <alpine@sev.monster>
 # Maintainer: sev <alpine@sev.monster>
 pkgname=mympd
-pkgver=9.3.4
-pkgrel=0
+pkgver=10.3.0
+pkgrel=1
 pkgdesc="myMPD is a standalone and mobile friendly web-based MPD client."
 url="https://jcorporation.github.io/myMPD/"
 arch="all"
@@ -14,7 +14,7 @@ depends="libid3tag flac lua5.4-libs pcre2"
 makedepends="cmake>=3.4 perl libid3tag-dev flac-dev linux-headers lua5.4-dev pcre2-dev jq"
 install="$pkgname.pre-install"
 subpackages="$pkgname-doc $pkgname-openrc"
-source="myMPD-$pkgver.tar.gz::https://github.com/jcorporation/myMPD/archive/refs/tags/v$pkgver.tar.gz"
+source="myMPD-$pkgver.tar.gz::https://github.com/jcorporation/myMPD/archive/refs/heads/v$pkgver.tar.gz"
 builddir="$srcdir/myMPD-$pkgver"
 
 build() {
@@ -23,16 +23,15 @@ build() {
 }
 
 check() {
-       cd "$builddir/release" || exit 1
-       # mympd has no safe way to start without it doing something
-       [ -x mympd >/dev/null 2>&1 ] || return 1
-       # we want to check a specific exit code so we have to turn off errexit
-       set +e
+       cd "$builddir/release/bin" || exit 1
+       ./mympd -h >/dev/null 2>&1 || return 1
        if [ -x cli_tools/mympd-script ]; then
-               ./cli_tools/mympd-script -h >/dev/null 2>&1
+               # we want to check exit code so we have to turn off errexit
+               set +e
+               ./mympd-script -h >/dev/null 2>&1
                [ $? -ne 1 ] && return 1
+               set -e
        fi
-       set -e
 }
 
 package() {
@@ -41,5 +40,5 @@ package() {
 }
 
 sha512sums="
-ad0724208dd7b6f48fad5adef5275f4ecb4d743dd80864e2ad39f66f1238bab284dda462d893566ad772f89956bffecaf08b88108ad5a649a6153beb6283d9ee  myMPD-9.3.4.tar.gz
+8c0d4aa0d26ca42b96e8ed50db4e7a8f23b8f81f1534e29c29334842735c1a77a6ad8ad785c28afe558e2b26078eae50aef4a9af9f26dc24760dd0b63afccb8f  myMPD-10.3.0.tar.gz
 "
This page took 0.059893 seconds and 4 git commands to generate.