]> git.sev.monster Git - aports.git/blobdiff - testing/mympd/APKBUILD
testing/mympd: upgrade to 10.1.5
[aports.git] / testing / mympd / APKBUILD
index bdb70cd3039fe0095d98210fdfd87a13a751c193..1efe3f2518f30bdd5d8ae97ad79fa7a704b3e7b9 100644 (file)
@@ -1,44 +1,44 @@
 # Contributor: sev <alpine@sev.monster>
 # Maintainer: sev <alpine@sev.monster>
 pkgname=mympd
-pkgver=9.1.0
+pkgver=10.1.5
 pkgrel=0
-pkgdesc="myMPD is a standalone and mobile friendly web mpd client with a tiny footprint and advanced features."
-url="https://jcorporation.github.io"
+pkgdesc="myMPD is a standalone and mobile friendly web-based MPD client."
+url="https://jcorporation.github.io/myMPD/"
 arch="all"
-license="GPL-3.0"
+license="GPL-3.0-or-later"
 # for ssl support
-depends="libid3tag flac openssl>=1.1.0 lua5.4-libs pcre2"
-makedepends="cmake>=3.4 perl libid3tag-dev flac-dev linux-headers lua5.4-dev lua5.4-libs pcre2-dev"
+#depends="libid3tag flac openssl>=1.1.0 lua5.4-libs pcre2"
+#makedepends="cmake>=3.4 perl libid3tag-dev flac-dev openssl>=1.1.0 linux-headers lua5.4-dev pcre2-dev jq"
+depends="libid3tag flac lua5.4-libs pcre2"
+makedepends="cmake>=3.4 perl libid3tag-dev flac-dev linux-headers lua5.4-dev pcre2-dev jq"
 install="$pkgname.pre-install"
 subpackages="$pkgname-doc $pkgname-openrc"
 source="myMPD-$pkgver.tar.gz::https://github.com/jcorporation/myMPD/archive/refs/tags/v$pkgver.tar.gz"
 builddir="$srcdir/myMPD-$pkgver"
 
 build() {
-       cd "$builddir"
+       cd "$builddir" || exit 1
        ./build.sh release
 }
 
 check() {
-       cd "$builddir/release"
-       # mympd has no safe way to start without it doing something
-       [ -x mympd >/dev/null 2>&1 ] || return 1
-       # we want to check a specific exit code so we have to turn off errexit
-       set +e
+       cd "$builddir/release/bin" || exit 1
+       ./mympd -h >/dev/null 2>&1 || return 1
        if [ -x cli_tools/mympd-script ]; then
-               ./cli_tools/mympd-script -h >/dev/null 2>&1
+               # we want to check exit code so we have to turn off errexit
+               set +e
+               ./mympd-script -h >/dev/null 2>&1
                [ $? -ne 1 ] && return 1
+               set -e
        fi
-       set -e
 }
 
 package() {
        cd "$builddir/release" || exit 1
-       [ -z "${DESTDIR+x}" ] && DESTDIR=""
-       make DESTDIR="$pkgdir" install
+       DESTDIR="$pkgdir" make install
 }
 
 sha512sums="
-0edf284d4b146744d76433df0237e259e17ff9b4c5353dca7e257c4e1dceb66599926398d44da6928ace6c2306032170f249c2f63aa1a4646240be6d1abf0f8c  myMPD-9.1.0.tar.gz
+f6af54bb44298a26453fd2b749d1e4ac16f52359175d154db41f3832567854f75d924336a6ac86fa88124df12fdf208eb2f763a0bd8e5414ec7e1b8c59ecdcb5  myMPD-10.1.5.tar.gz
 "
This page took 0.319219 seconds and 4 git commands to generate.