# Contributor: sev <alpine@sev.monster>
# Maintainer: sev <alpine@sev.monster>
+# Based on upstream APKBUILD
+# https://github.com/jcorporation/myMPD/blob/master/contrib/packaging/alpine/APKBUILD.in
pkgname=mympd
-pkgver=9.1.2
+pkgver=12.0.4
pkgrel=0
-pkgdesc="myMPD is a standalone and mobile friendly web mpd client with a tiny footprint and advanced features."
-url="https://jcorporation.github.io"
+pkgdesc="myMPD is a standalone and mobile friendly web-based MPD client."
+url="https://jcorporation.github.io/myMPD/"
arch="all"
-license="GPL-3.0"
-# for ssl support
+license="GPL-3.0-or-later"
depends="libid3tag flac openssl>=1.1.0 lua5.4-libs pcre2"
-makedepends="cmake>=3.4 perl libid3tag-dev flac-dev linux-headers lua5.4-dev lua5.4-libs pcre2-dev"
+makedepends="cmake>=3.4 perl libid3tag-dev flac-dev openssl-dev>=1.1.0 linux-headers lua5.4-dev pcre2-dev jq"
install="$pkgname.pre-install"
-subpackages="$pkgname-doc $pkgname-openrc"
+subpackages="$pkgname-doc $pkgname-openrc $pkgname-dbg"
source="myMPD-$pkgver.tar.gz::https://github.com/jcorporation/myMPD/archive/refs/tags/v$pkgver.tar.gz"
builddir="$srcdir/myMPD-$pkgver"
build() {
- cd "$builddir"
+ cd "$builddir" || exit 1
./build.sh release
}
check() {
- cd "$builddir/release"
- # mympd has no safe way to start without it doing something
- [ -x mympd >/dev/null 2>&1 ] || return 1
- # we want to check a specific exit code so we have to turn off errexit
- set +e
+ cd "$builddir/release/bin" || exit 1
+ ./mympd -h >/dev/null 2>&1 || return 1
if [ -x cli_tools/mympd-script ]; then
- ./cli_tools/mympd-script -h >/dev/null 2>&1
+ # we want to check exit code so we have to turn off errexit
+ set +e
+ ./mympd-script -h >/dev/null 2>&1
[ $? -ne 1 ] && return 1
+ set -e
fi
- set -e
}
package() {
cd "$builddir/release" || exit 1
- [ -z "${DESTDIR+x}" ] && DESTDIR=""
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" make install
}
sha512sums="
-fe16a38861daa87b16d72a6fcc4d7003f1b84e535da1e40c3dea3a04776c98881a6e658684b376ae1d2d0c366352f111c5d93f224c8315904ff0e61e36a4cf5c myMPD-9.1.2.tar.gz
+ab3391c294b9ee7a82c61021d950241cd395ab851496407b0cc4556fb3f58c3d70299dca719f37ac0de7535b5aef5450c5663762d2e39281ee3a23db45f4c997 myMPD-12.0.4.tar.gz
"