# Contributor: sev <alpine@sev.monster>
# Maintainer: sev <alpine@sev.monster>
pkgname=mympd
-pkgver=9.3.1
-pkgrel=0
+pkgver=10.3.0
+pkgrel=1
pkgdesc="myMPD is a standalone and mobile friendly web-based MPD client."
url="https://jcorporation.github.io/myMPD/"
arch="all"
makedepends="cmake>=3.4 perl libid3tag-dev flac-dev linux-headers lua5.4-dev pcre2-dev jq"
install="$pkgname.pre-install"
subpackages="$pkgname-doc $pkgname-openrc"
-source="myMPD-$pkgver.tar.gz::https://github.com/jcorporation/myMPD/archive/refs/tags/v$pkgver.tar.gz"
+source="myMPD-$pkgver.tar.gz::https://github.com/jcorporation/myMPD/archive/refs/heads/v$pkgver.tar.gz"
builddir="$srcdir/myMPD-$pkgver"
build() {
}
check() {
- cd "$builddir/release" || exit 1
- # mympd has no safe way to start without it doing something
- [ -x mympd >/dev/null 2>&1 ] || return 1
- # we want to check a specific exit code so we have to turn off errexit
- set +e
+ cd "$builddir/release/bin" || exit 1
+ ./mympd -h >/dev/null 2>&1 || return 1
if [ -x cli_tools/mympd-script ]; then
- ./cli_tools/mympd-script -h >/dev/null 2>&1
+ # we want to check exit code so we have to turn off errexit
+ set +e
+ ./mympd-script -h >/dev/null 2>&1
[ $? -ne 1 ] && return 1
+ set -e
fi
- set -e
}
package() {
}
sha512sums="
-a5c8d63842d7c5139af465d0b065913a1d9f648bcfff8f0ad0d2055ad10cdcb525fd6f0fbba61ef513f868779192e67bfbc7c7e3508e00f79149e1de1fe90a63 myMPD-9.3.1.tar.gz
+8c0d4aa0d26ca42b96e8ed50db4e7a8f23b8f81f1534e29c29334842735c1a77a6ad8ad785c28afe558e2b26078eae50aef4a9af9f26dc24760dd0b63afccb8f myMPD-10.3.0.tar.gz
"