]> git.sev.monster Git - aports.git/blobdiff - testing/mympd/APKBUILD
mympd: bump version, cronwrap: use binary basename
[aports.git] / testing / mympd / APKBUILD
index 3a3fc2cce5ee41771670c10242d87e5fcbdd05c6..cfe09bdd19f8988f82380603708910f3b5ebcae9 100644 (file)
@@ -1,14 +1,14 @@
 # Contributor: sev <alpine@sev.monster>
 # Maintainer: sev <alpine@sev.monster>
 pkgname=mympd
-pkgver=7.0.2
+pkgver=8.0.2
 pkgrel=1
 pkgdesc="myMPD is a standalone and mobile friendly web mpd client with a tiny footprint and advanced features."
 url="https://jcorporation.github.io"
 arch="all"
 license="GPL-2.0-or-later"
-depends="libid3tag flac openssl>=1.1.0 lua5.3 pcre"
-makedepends="cmake>=3.4 perl pcre-dev openssl-dev>=1.1.0 libid3tag-dev flac-dev lua5.3-dev"
+depends="libid3tag flac openssl>=1.1.0 lua5.3-libs pcre"
+makedepends="cmake>=3.4 perl libid3tag-dev flac-dev openssl-dev>=1.1.0 linux-headers lua5.3-dev lua5.3-libs pcre-dev"
 install="$pkgname.pre-install $pkgname.post-install"
 subpackages="$pkgname-doc $pkgname-openrc"
 source="myMPD-$pkgver.tar.gz::https://github.com/jcorporation/myMPD/archive/refs/tags/v$pkgver.tar.gz"
@@ -26,8 +26,10 @@ check() {
        # we want to check a specific exit code so we have to turn off errexit
        set +e
        for x in config script; do
-               ./cli_tools/mympd-$x -h >/dev/null 2>&1
-               [ $? -ne 1 ] && return 1
+               if [ -x cli_tools/mympd-$x ]; then
+                       ./cli_tools/mympd-$x -h >/dev/null 2>&1
+                       [ $? -ne 1 ] && return 1
+               fi
        done
        set -e
 }
@@ -39,5 +41,5 @@ package() {
 }
 
 sha512sums="
-98a7464c307797b5b3b3ab56a7dfc2bab47a366e4cc4c48c2239915a14152bd3d6946219ee634baf4a1d36ba92778393100e3e7a16054aa1f85381c34303bd3f  myMPD-7.0.2.tar.gz
+7a49659fec8f4a6926fdf7d4ede5b625ba7e3a3f48c828b2103313a24582019577d13b2075457f1007c3d57839090eafc0392a0c2b569a74077c5ef0bbb08d7d  myMPD-8.0.2.tar.gz
 "
This page took 0.036411 seconds and 4 git commands to generate.