-# Contributor: sev <alpine@sev.monster>
-# Maintainer: sev <alpine@sev.monster>
+# Contributor: sev <sev+alpine@sev.monster>
+# Maintainer: sev <sev+alpine@sev.monster>
+# Based on upstream APKBUILD
+# https://github.com/jcorporation/myMPD/blob/master/contrib/packaging/alpine/APKBUILD.in
pkgname=mympd
-pkgver=8.0.2
-pkgrel=1
-pkgdesc="myMPD is a standalone and mobile friendly web mpd client with a tiny footprint and advanced features."
-url="https://jcorporation.github.io"
+pkgver=13.0.6
+pkgrel=0
+pkgdesc="myMPD is a standalone and mobile friendly web-based MPD client."
+url="https://jcorporation.github.io/myMPD/"
arch="all"
-license="GPL-2.0-or-later"
-depends="libid3tag flac openssl>=1.1.0 lua5.3-libs pcre"
-makedepends="cmake>=3.4 perl libid3tag-dev flac-dev openssl-dev>=1.1.0 linux-headers lua5.3-dev lua5.3-libs pcre-dev"
-install="$pkgname.pre-install $pkgname.post-install"
-subpackages="$pkgname-doc $pkgname-openrc"
+license="GPL-3.0-or-later"
+depends="libid3tag flac openssl>=1.1.0 lua5.4-libs pcre2"
+makedepends="cmake>=3.4 perl libid3tag-dev flac-dev openssl-dev>=1.1.0 linux-headers lua5.4-dev pcre2-dev jq"
+install="$pkgname.pre-install"
+subpackages="$pkgname-doc $pkgname-openrc $pkgname-dbg"
source="myMPD-$pkgver.tar.gz::https://github.com/jcorporation/myMPD/archive/refs/tags/v$pkgver.tar.gz"
builddir="$srcdir/myMPD-$pkgver"
build() {
- cd "$builddir"
+ cd "$builddir" || exit 1
./build.sh release
}
check() {
- cd "$builddir/release"
- # mympd has no safe way to start without it doing something
- [ -x mympd >/dev/null 2>&1 ] || return 1
- # we want to check a specific exit code so we have to turn off errexit
- set +e
- for x in config script; do
- if [ -x cli_tools/mympd-$x ]; then
- ./cli_tools/mympd-$x -h >/dev/null 2>&1
- [ $? -ne 1 ] && return 1
- fi
- done
- set -e
+ cd "$builddir/release/bin" || exit 1
+ ./mympd -h >/dev/null 2>&1 || return 1
+ if [ -x cli_tools/mympd-script ]; then
+ # we want to check exit code so we have to turn off errexit
+ set +e
+ ./mympd-script -h >/dev/null 2>&1
+ [ $? -ne 1 ] && return 1
+ set -e
+ fi
}
package() {
cd "$builddir/release" || exit 1
- [ -z "${DESTDIR+x}" ] && DESTDIR=""
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" make install
}
sha512sums="
-7a49659fec8f4a6926fdf7d4ede5b625ba7e3a3f48c828b2103313a24582019577d13b2075457f1007c3d57839090eafc0392a0c2b569a74077c5ef0bbb08d7d myMPD-8.0.2.tar.gz
+bb4c6b02b81e5b3ee4b0953ed4815faed74d8ab28c70c0228efa539771714d691b2955f8bf296e0e7e7785a1b8a50768e50a5c8a1bbfe358f25df70e380c30cf myMPD-13.0.6.tar.gz
"