]> git.sev.monster Git - aports.git/blobdiff - testing/mympd/APKBUILD
testing/mympd: upgrade to 18.0.0
[aports.git] / testing / mympd / APKBUILD
index cfe09bdd19f8988f82380603708910f3b5ebcae9..609b2f1c7b84e65a74394d52510b86ff901bb931 100644 (file)
@@ -1,45 +1,45 @@
-# Contributor: sev <alpine@sev.monster>
-# Maintainer: sev <alpine@sev.monster>
+# Contributor: sev <sev+alpine@sev.monster>
+# Maintainer: sev <sev+alpine@sev.monster>
+# Based on upstream APKBUILD
+# https://github.com/jcorporation/myMPD/blob/master/contrib/packaging/alpine/APKBUILD.in
 pkgname=mympd
-pkgver=8.0.2
-pkgrel=1
-pkgdesc="myMPD is a standalone and mobile friendly web mpd client with a tiny footprint and advanced features."
-url="https://jcorporation.github.io"
+_pkgver=16.0.0
+pkgver=18.0.0
+pkgrel=0
+pkgdesc="myMPD is a standalone and mobile friendly web-based MPD client."
+url="https://jcorporation.github.io/myMPD/"
 arch="all"
-license="GPL-2.0-or-later"
-depends="libid3tag flac openssl>=1.1.0 lua5.3-libs pcre"
-makedepends="cmake>=3.4 perl libid3tag-dev flac-dev openssl-dev>=1.1.0 linux-headers lua5.3-dev lua5.3-libs pcre-dev"
-install="$pkgname.pre-install $pkgname.post-install"
-subpackages="$pkgname-doc $pkgname-openrc"
-source="myMPD-$pkgver.tar.gz::https://github.com/jcorporation/myMPD/archive/refs/tags/v$pkgver.tar.gz"
-builddir="$srcdir/myMPD-$pkgver"
+license="GPL-3.0-or-later"
+depends="libid3tag flac openssl>=1.1.0 lua5.4-libs pcre2"
+makedepends="cmake>=3.4 perl libid3tag-dev flac-dev openssl-dev>=1.1.0 linux-headers lua5.4-dev pcre2-dev jq"
+install="$pkgname.pre-install"
+subpackages="$pkgname-doc $pkgname-openrc $pkgname-dbg"
+#source="myMPD-$pkgver.tar.gz::https://github.com/jcorporation/myMPD/archive/refs/tags/v$pkgver.tar.gz"
+source="myMPD-$_pkgver.tar.gz::https://github.com/jcorporation/myMPD/archive/refs/heads/v16.0.0.tar.gz"
+builddir="$srcdir/myMPD-$_pkgver"
 
 build() {
-       cd "$builddir"
+       cd "$builddir" || exit 1
        ./build.sh release
 }
 
 check() {
-       cd "$builddir/release"
-       # mympd has no safe way to start without it doing something
-       [ -x mympd >/dev/null 2>&1 ] || return 1
-       # we want to check a specific exit code so we have to turn off errexit
-       set +e
-       for x in config script; do
-               if [ -x cli_tools/mympd-$x ]; then
-                       ./cli_tools/mympd-$x -h >/dev/null 2>&1
-                       [ $? -ne 1 ] && return 1
-               fi
-       done
-       set -e
+       cd "$builddir/release/bin" || exit 1
+       ./mympd -h >/dev/null 2>&1 || return 1
+       if [ -x cli_tools/mympd-script ]; then
+               # we want to check exit code so we have to turn off errexit
+               set +e
+               ./mympd-script -h >/dev/null 2>&1
+               [ $? -ne 1 ] && return 1
+               set -e
+       fi
 }
 
 package() {
        cd "$builddir/release" || exit 1
-       [ -z "${DESTDIR+x}" ] && DESTDIR=""
-       make DESTDIR="$pkgdir" install
+       DESTDIR="$pkgdir" make install
 }
 
 sha512sums="
-7a49659fec8f4a6926fdf7d4ede5b625ba7e3a3f48c828b2103313a24582019577d13b2075457f1007c3d57839090eafc0392a0c2b569a74077c5ef0bbb08d7d  myMPD-8.0.2.tar.gz
+3cc3e286acc07ad17e5c2d94376d2b7b4c6204056196587105ba7477f60c08c1ffebc2748836d2fda64c014c480fe7cfc6d407b7cd665d89fc90cd250ac37520  myMPD-16.0.0.tar.gz
 "
This page took 0.04396 seconds and 4 git commands to generate.