# Contributor: sev <alpine@sev.monster>
# Maintainer: sev <alpine@sev.monster>
pkgname=mympd
-pkgver=8.0.2
-pkgrel=1
+pkgver=9.1.2
+pkgrel=0
pkgdesc="myMPD is a standalone and mobile friendly web mpd client with a tiny footprint and advanced features."
url="https://jcorporation.github.io"
arch="all"
-license="GPL-2.0-or-later"
-depends="libid3tag flac openssl>=1.1.0 lua5.3-libs pcre"
-makedepends="cmake>=3.4 perl libid3tag-dev flac-dev openssl-dev>=1.1.0 linux-headers lua5.3-dev lua5.3-libs pcre-dev"
-install="$pkgname.pre-install $pkgname.post-install"
+license="GPL-3.0"
+# for ssl support
+depends="libid3tag flac openssl>=1.1.0 lua5.4-libs pcre2"
+makedepends="cmake>=3.4 perl libid3tag-dev flac-dev linux-headers lua5.4-dev lua5.4-libs pcre2-dev"
+install="$pkgname.pre-install"
subpackages="$pkgname-doc $pkgname-openrc"
source="myMPD-$pkgver.tar.gz::https://github.com/jcorporation/myMPD/archive/refs/tags/v$pkgver.tar.gz"
builddir="$srcdir/myMPD-$pkgver"
[ -x mympd >/dev/null 2>&1 ] || return 1
# we want to check a specific exit code so we have to turn off errexit
set +e
- for x in config script; do
- if [ -x cli_tools/mympd-$x ]; then
- ./cli_tools/mympd-$x -h >/dev/null 2>&1
- [ $? -ne 1 ] && return 1
- fi
- done
+ if [ -x cli_tools/mympd-script ]; then
+ ./cli_tools/mympd-script -h >/dev/null 2>&1
+ [ $? -ne 1 ] && return 1
+ fi
set -e
}
}
sha512sums="
-7a49659fec8f4a6926fdf7d4ede5b625ba7e3a3f48c828b2103313a24582019577d13b2075457f1007c3d57839090eafc0392a0c2b569a74077c5ef0bbb08d7d myMPD-8.0.2.tar.gz
+fe16a38861daa87b16d72a6fcc4d7003f1b84e535da1e40c3dea3a04776c98881a6e658684b376ae1d2d0c366352f111c5d93f224c8315904ff0e61e36a4cf5c myMPD-9.1.2.tar.gz
"