]> git.sev.monster Git - aports.git/blobdiff - testing/mympd/APKBUILD
mympd: update to 9.3.1
[aports.git] / testing / mympd / APKBUILD
index 8e1713237b5807033cbc2b60433608638c0a679a..966d0e8b5d340dd0caea9c5cd2f0f92487653fbd 100644 (file)
@@ -1,27 +1,29 @@
 # Contributor: sev <alpine@sev.monster>
 # Maintainer: sev <alpine@sev.monster>
 pkgname=mympd
-pkgver=9.0.0
+pkgver=9.3.1
 pkgrel=0
-pkgdesc="myMPD is a standalone and mobile friendly web mpd client with a tiny footprint and advanced features."
-url="https://jcorporation.github.io"
+pkgdesc="myMPD is a standalone and mobile friendly web-based MPD client."
+url="https://jcorporation.github.io/myMPD/"
 arch="all"
-license="GPL-3.0"
+license="GPL-3.0-or-later"
 # for ssl support
-depends="libid3tag flac openssl>=1.1.0 lua5.4-libs pcre2"
-makedepends="cmake>=3.4 perl libid3tag-dev flac-dev linux-headers lua5.4-dev lua5.4-libs pcre2-dev"
+#depends="libid3tag flac openssl>=1.1.0 lua5.4-libs pcre2"
+#makedepends="cmake>=3.4 perl libid3tag-dev flac-dev openssl>=1.1.0 linux-headers lua5.4-dev pcre2-dev jq"
+depends="libid3tag flac lua5.4-libs pcre2"
+makedepends="cmake>=3.4 perl libid3tag-dev flac-dev linux-headers lua5.4-dev pcre2-dev jq"
 install="$pkgname.pre-install"
 subpackages="$pkgname-doc $pkgname-openrc"
 source="myMPD-$pkgver.tar.gz::https://github.com/jcorporation/myMPD/archive/refs/tags/v$pkgver.tar.gz"
 builddir="$srcdir/myMPD-$pkgver"
 
 build() {
-       cd "$builddir"
+       cd "$builddir" || exit 1
        ./build.sh release
 }
 
 check() {
-       cd "$builddir/release"
+       cd "$builddir/release" || exit 1
        # mympd has no safe way to start without it doing something
        [ -x mympd >/dev/null 2>&1 ] || return 1
        # we want to check a specific exit code so we have to turn off errexit
@@ -35,10 +37,9 @@ check() {
 
 package() {
        cd "$builddir/release" || exit 1
-       [ -z "${DESTDIR+x}" ] && DESTDIR=""
-       make DESTDIR="$pkgdir" install
+       DESTDIR="$pkgdir" make install
 }
 
 sha512sums="
-0b9bf8ba68bd9b892c0e0bd83e9efc2763038eeadc604f2c977390716f95e5a5cd608be24548d9e01608ebd7f0737a0ed279f002ab07e8ed8ce8629458bfc892  myMPD-9.0.0.tar.gz
+a5c8d63842d7c5139af465d0b065913a1d9f648bcfff8f0ad0d2055ad10cdcb525fd6f0fbba61ef513f868779192e67bfbc7c7e3508e00f79149e1de1fe90a63  myMPD-9.3.1.tar.gz
 "
This page took 0.046124 seconds and 4 git commands to generate.