-# Contributor: sev <alpine@sev.monster>
-# Maintainer: sev <alpine@sev.monster>
+# Contributor: sev <sev+alpine@sev.monster>
+# Maintainer: sev <sev+alpine@sev.monster>
+# Based on upstream APKBUILD
+# https://github.com/jcorporation/myMPD/blob/master/contrib/packaging/alpine/APKBUILD.in
pkgname=mympd
-pkgver=9.3.4
+_pkgver=16.0.0
+pkgver=18.1.2
pkgrel=0
pkgdesc="myMPD is a standalone and mobile friendly web-based MPD client."
url="https://jcorporation.github.io/myMPD/"
arch="all"
license="GPL-3.0-or-later"
-# for ssl support
-#depends="libid3tag flac openssl>=1.1.0 lua5.4-libs pcre2"
-#makedepends="cmake>=3.4 perl libid3tag-dev flac-dev openssl>=1.1.0 linux-headers lua5.4-dev pcre2-dev jq"
-depends="libid3tag flac lua5.4-libs pcre2"
-makedepends="cmake>=3.4 perl libid3tag-dev flac-dev linux-headers lua5.4-dev pcre2-dev jq"
+depends="libid3tag flac openssl>=1.1.0 lua5.4-libs pcre2"
+makedepends="cmake>=3.4 perl libid3tag-dev flac-dev openssl-dev>=1.1.0 linux-headers lua5.4-dev pcre2-dev jq"
install="$pkgname.pre-install"
-subpackages="$pkgname-doc $pkgname-openrc"
-source="myMPD-$pkgver.tar.gz::https://github.com/jcorporation/myMPD/archive/refs/tags/v$pkgver.tar.gz"
-builddir="$srcdir/myMPD-$pkgver"
+subpackages="$pkgname-doc $pkgname-openrc $pkgname-dbg"
+#source="myMPD-$pkgver.tar.gz::https://github.com/jcorporation/myMPD/archive/refs/tags/v$pkgver.tar.gz"
+source="myMPD-$_pkgver.tar.gz::https://github.com/jcorporation/myMPD/archive/refs/heads/v16.0.0.tar.gz"
+builddir="$srcdir/myMPD-$_pkgver"
build() {
cd "$builddir" || exit 1
}
check() {
- cd "$builddir/release" || exit 1
- # mympd has no safe way to start without it doing something
- [ -x mympd >/dev/null 2>&1 ] || return 1
- # we want to check a specific exit code so we have to turn off errexit
- set +e
+ cd "$builddir/release/bin" || exit 1
+ ./mympd -h >/dev/null 2>&1 || return 1
if [ -x cli_tools/mympd-script ]; then
- ./cli_tools/mympd-script -h >/dev/null 2>&1
+ # we want to check exit code so we have to turn off errexit
+ set +e
+ ./mympd-script -h >/dev/null 2>&1
[ $? -ne 1 ] && return 1
+ set -e
fi
- set -e
}
package() {
}
sha512sums="
-ad0724208dd7b6f48fad5adef5275f4ecb4d743dd80864e2ad39f66f1238bab284dda462d893566ad772f89956bffecaf08b88108ad5a649a6153beb6283d9ee myMPD-9.3.4.tar.gz
+3cc3e286acc07ad17e5c2d94376d2b7b4c6204056196587105ba7477f60c08c1ffebc2748836d2fda64c014c480fe7cfc6d407b7cd665d89fc90cd250ac37520 myMPD-16.0.0.tar.gz
"