]> git.sev.monster Git - aports.git/blobdiff - testing/mympd/APKBUILD
testing/mympd: upgrade to 18.1.2
[aports.git] / testing / mympd / APKBUILD
index 86f8d56a798d9519473eb4ccee19ee5b15f08d27..2490a3c4d97e92f7e6d5b7565d2044a3433d2c18 100644 (file)
@@ -1,21 +1,22 @@
-# Contributor: sev <alpine@sev.monster>
-# Maintainer: sev <alpine@sev.monster>
+# Contributor: sev <sev+alpine@sev.monster>
+# Maintainer: sev <sev+alpine@sev.monster>
+# Based on upstream APKBUILD
+# https://github.com/jcorporation/myMPD/blob/master/contrib/packaging/alpine/APKBUILD.in
 pkgname=mympd
 pkgname=mympd
-pkgver=10.1.6
+_pkgver=16.0.0
+pkgver=18.1.2
 pkgrel=0
 pkgdesc="myMPD is a standalone and mobile friendly web-based MPD client."
 url="https://jcorporation.github.io/myMPD/"
 arch="all"
 license="GPL-3.0-or-later"
 pkgrel=0
 pkgdesc="myMPD is a standalone and mobile friendly web-based MPD client."
 url="https://jcorporation.github.io/myMPD/"
 arch="all"
 license="GPL-3.0-or-later"
-# for ssl support
-#depends="libid3tag flac openssl>=1.1.0 lua5.4-libs pcre2"
-#makedepends="cmake>=3.4 perl libid3tag-dev flac-dev openssl>=1.1.0 linux-headers lua5.4-dev pcre2-dev jq"
-depends="libid3tag flac lua5.4-libs pcre2"
-makedepends="cmake>=3.4 perl libid3tag-dev flac-dev linux-headers lua5.4-dev pcre2-dev jq"
+depends="libid3tag flac openssl>=1.1.0 lua5.4-libs pcre2"
+makedepends="cmake>=3.4 perl libid3tag-dev flac-dev openssl-dev>=1.1.0 linux-headers lua5.4-dev pcre2-dev jq"
 install="$pkgname.pre-install"
 install="$pkgname.pre-install"
-subpackages="$pkgname-doc $pkgname-openrc"
-source="myMPD-$pkgver.tar.gz::https://github.com/jcorporation/myMPD/archive/refs/tags/v$pkgver.tar.gz"
-builddir="$srcdir/myMPD-$pkgver"
+subpackages="$pkgname-doc $pkgname-openrc $pkgname-dbg"
+#source="myMPD-$pkgver.tar.gz::https://github.com/jcorporation/myMPD/archive/refs/tags/v$pkgver.tar.gz"
+source="myMPD-$_pkgver.tar.gz::https://github.com/jcorporation/myMPD/archive/refs/heads/v16.0.0.tar.gz"
+builddir="$srcdir/myMPD-$_pkgver"
 
 build() {
        cd "$builddir" || exit 1
 
 build() {
        cd "$builddir" || exit 1
@@ -40,5 +41,5 @@ package() {
 }
 
 sha512sums="
 }
 
 sha512sums="
-f1636645efe3b2b1838615b1a3474956520c99c070d00f5c2a5d474dbdd6ecd047e1379c286592016a06304dc981fab173d3e7bc83221c7b8153ff6724c453da  myMPD-10.1.6.tar.gz
+3cc3e286acc07ad17e5c2d94376d2b7b4c6204056196587105ba7477f60c08c1ffebc2748836d2fda64c014c480fe7cfc6d407b7cd665d89fc90cd250ac37520  myMPD-16.0.0.tar.gz
 "
 "
This page took 0.035365 seconds and 4 git commands to generate.